Changing assablies positioning, if its wrong.

Basically I made Assembly and now, when i wanned to take some good pictures of it, I understud, that its positioned wrong, i mean Objects front are facing down, so all the floors reflection is totally wrong, and so on. I added a SS, so u know, what i mean, as that engine is pretty complicated already, i badly don't want to remake it, in order, to get it positioned right (but I want, as thats pretty serious and i want it to be perfect)
[URL=http://imageshack.us/photo/my-images/15/postioning.jpg/][IMG]http://imageshack.us/a/img15/9850/postioning.jpg[/IMG][/URL]

I tried to put some Constrain with Origin of ''room'' to main body of Engine, but just got ''not responding'' and needed to restart Inventor, I tried to just rotate main body of engine to right positioning, and hoped that rest would follow, but it didn't , and i got some hardcore error again about broken constrains.

Is there any chance to get it positioned in right directions now?

Thank You.

Answer
 
Comments 0

23 Answers

You should have a part that is grounded. remove the ground and you should be able to position the whole assembly wherever you want.

 
Comments 0

I had mainbody of engine as grounded, but i removed it before aswell, forgot to mention it, so than i tried to rotate it, but it just gave me errors and not responding, I will try to do it again, there are just so many components and constrains between them, that its pretty hard, as all insaid is full of parts.

 
Comments 0

I tried to rotate 1 side of engines body to right orientation, hopeing, that rest will just follow to that, as nothing is grounded (except sub-assemblies) but instead part i just rotated felt back in old position where it was, when i touched engine again. I will check if i dont have any constrains between room's origin and engine, but i think I removed all i had.

Is it worth to try to take ''grounded'' off all sub-assemblies, as i think its not really a problem here, as grounded of them, doesnt apply in main one. ?

 
Comments 0

I dont think removing the grounded from subassemblies will work. It will make it worst.
What Inventor do you have?

 
Comments 0

2013 student version.

well i tried many different things, and nothing really worked, so i already started to make new, this time rightly positioned engine with many more sub-assemblies this time, to make it all easier manageable and i will work my way out with right materials aswell. There are many componenets I still have to make for it, but I will keep some pictures prolly posted on how its going, as it will look pretty realistic now.

 
Comments 0

cool, i was going to say that if you could send me the files i could try and fix the orientation. But since you already started from scratch. Neverming.
Good luck with the project!

I have 2013 also, full version, whenever you need help, just shoot me a message and i will try and help you.

 
Comments 0

I guess i will need loads of help later anyway, i wouldn't remake it, but since its pretty big, and have like loads of files in the folder + in assembly aswell, that are not really needed (for example i will have to remake starter, but all parts i made are still somewhere in that engine folder, i dont know which i need and there are just too many of them, to find the ones i dont need, and delete them :D ) + if i will make new one by using even more sub-assemblies it will be easier to hide parts when i dont need them, for example now, if i hide body, all the screws are still there and are messing up the looks and make it hard for me to work insaid it. Atm making mainbody, when its ready, i will post a picture.

 
Comments 0

than maybe i could send You the Engine, as in that point, i can easy avoid totally remaking it. Maybe we can use Skype as its pretty easy that way + You can ask me if something doesn't work out etc really quick. ?

 
Comments 0

Oh ok. Than i will just upload files, and You can have a look at them when u have some free time.

 
Comments 0

The quick solution is, using the viewing cube set your view so that you are looking onto what you want to be the top of the model (by you r description this is currently the front view?). Right click on the home icon and then set the current view as top.

Now when you render, the floor should be where it is supposed to be.

 
Comments 0

You have some files missing:

Rolling bearing NA6904 GB_T 5801-2006
JIS B 1538 - EN 14 14x35x8
Bearing F 617_9 GB_T 7218-1995

 
Comments 0

weird, i uploaded all folder that had files from engine in it.

 
Comments 0

Do you know what folder those parts were in? The specific folder?

 
Comments 0

Should be as : Engine/Design Accelerator/..

there is Bearing 1, Bearing 2, Bearing 3.

 
Comments 0

Did you try doing what Rodger.H said?

 
Comments 0

Not yet, as i am rendering image atm, i will do it in a sec when it will finish, on my PC it just takes so looong to do that. :D i will post how it went than.

 
Comments 0

ok let me know so i dont have to do ti if it works.

 
Comments 0

That worked, thx a lot! :) for me to get that one render i just uploaded, it took like 9 hours, as i set it to max quality, so all the time I was sleeping it was rendering and now, when i woke up, it wasn't even finished yet :D

 
Comments 0