Downloads appear as "certificate trust list"

I'm new to GrabCAD and tried downloading some files to open in solidworks. However, when I try to open it, it doesn't appear as an option for solidworks. The files are listed as "Certificate Trust List". I tried another download of a different model and the same issue came up. Any suggestions?

Answer
 
Comments 0

4 Answers

Welcome to GrabCAD.

I've never had any trouble downloading, saving or opening SolidWorks files from the site.
- Could you provide a link to a model that is not working?
- What browser are you using?
- Does the error occur if you try to save the file? Or are you trying to open the file directly from the browser?

 
Comments 2

Windows uses .stl extension for certificate trust lists by default, but the extension is more commonly used for the stereolithography file format, a common CAD file type.

Right Click -> Open With -> Solidworks

If that is not listed, your best bet is to contact Solidworks support or reinstall Solidworks.

Johannes
Developer @ GrabCAD

 
Comments 0

It's an STL file (generic 3D format). Windows explorer doesn't like recognising them but open Solidworks and open from file > open

You can then import and then save as a Solidworks file. You won't have the feature tree, just solid bodies.

 
Comments 0

Alex,

I've ran into this problem before with stl files. Typically in softwares like inventor and solidworks, they are not very flexible and come in as one complicated mesh part. stl files today are more or less used for 3D printing softwares like catalyst. If possible, it would be best to get the file as a step file which is typically the most flexible of all files across engineering type softwares.

 
Comments 0