How do I get a less spotty render?

When I'm rendering a model, the very reflective surfaces are rednered correctly, but the less reflective surfaces don't render the way I want them to. For example, the picture attached has brushed aluminum for the black engine parts, but it looks dull and spotty. I want to make them look as reflective as the previews in the program for the material. Please help, thanks

Answer
 
Comments 1

5 Answers

you can change reflectivity for each material :appearances>edit material>advanced>illumination>and slide up reflection amount .
you can also change "scene reflectivity"edit scene>illumination>scene reflectivity

 
Comments 0

Sorry I forgot something very important
in this case you have too much "specular spread"
you must reduce it

 
Comments 0

Check the illumination options in Appearances for the advanced option. You can change a lot of options there to get desired result. Good Luck.

 
Comments 0

Check that you have only one Appearance assigned to that Part/Body/Face. It may be that the one you want is not the one that is being displayed.

If a part is appearing totally black, open it and select the display state that it already has. (This sounds bizarre but it fixes the problem).

 
Comments 0

What render software are you usen?
:P

 
Comments 1