Ask and answer engineering questions

Learn from millions of experts

Feed

How I can activate "real view graphics" in my "Solidworks 2015 X 64 Bit,SP2" ? My operating system is Windows 7 X 64 Bit ,SP1 and my graphics card is AMD Radeon HD 7500M/7600M Series . I have already tried "RealHack 3.9.1" but it is not working. :(

By Mehdi Masud on 05 Jun 10:08 40 answers 28 comments

It would be very helpful if anyone answered my question with a tutorial. I have already tried a tutorial from Grabcad but it is very much confusing. Please help.

40 answers

  • Leucetius
    Leucetius over 2 years ago

    1.) Open up the registry editor (Start Button -> Run... -> "regedit")
    2.) Navigate to "HKEY_CURRENT_USER\Software\SolidWorks\SOLIDWORKS 2015\Performance\Graphics\Hardware\Current"
    3.) On the right side doubleclick on "Renderer"
    4.) copy (Strg+C) the Value
    Since I have a GeForce Card mine is "GeForce GTX 970/PCIe/SSE2". Yours will be different, mentioning an AMD card. It is important to copy ALL what's in value.
    5.) Navigate to "HKEY_CURRENT_USER\Software\SolidWorks\SOLIDWORKS 2015\Performance\Graphics\Hardware\Gl2Shaders\R420"
    6.) On the left side (the treeview) rightclick on "R420" and choose "New / Key"
    7.) Rename the new key with the copied value (Strg+V)
    8.) Click another Key and back to your newly created to make sure you are editing the right values. The right side should be empty but an entry (Default) whose data is "value not set"
    9.) rightclick in the right side and create "New / DWORD (32-bit) Value"
    10.) Rename the DWORD to "Workarounds" and, after that, doublecklick it
    11.) Leave the "Base" to "Hexadecimal" and enter 30008 into the field "Value data"
    12.) Leave the Registryeditor open and start Solidworks. Create a new part / open an old one and try to enable RealView.

    If RealView is still greyed out:
    13.) Close Solidworks and go back to the registry editor. Doubleclick the DWORD "Workarounds" and change the "Value data" to 30408
    14.) Fire up Solidworks and try again to activate Realview (Part or Assembly open)

    If RealView is STILL greyed out:
    15.) Freakout - I can't help you mate.

    Edit: Reported working solution. And for SOME who keep telling "You need a Quattro card": look at the appended screenshot. RealView with all bells and whistles with an GTX 970.

  • Plecostomus Prime
    Plecostomus Prime over 2 years ago

    For anyone looking into doing this, be sure to add the new key (in steps 5 and 6 of Leucetius' answer) to the correct folder for your graphics card. You will probably need to find the equivalent workstation card to your graphics card, then find that card's folder under GL2Shaders, then add your new key to that folder. For example, I have an Nvidia Geforce GTX 560, which uses the Fermi micro-architecture. So I Google'd the Quadros, and found that the Quadro 600, 5000, and 6000 are also based on Fermi, and those three Quadros are under the NV40 folder in the registry. So, for steps 5 and 6, I used "NV40" instead of "R420".

    In short, "R420" is specific to the original poster's card, you will need to match your card to the proper folder.

  • Karl Bowles
    Karl Bowles about 2 years ago

    To expand on Plecostomus Prime's post (thanks!!), for my GTX770 it was the NV40 folder that was needed.

    To find out which yours is, Google "[your card] architecture" and then once you've found out what architecture your card uses, Google "[your card's architecture] quadro". For my GTX770, the architecture is Kepler, so I searched for Kepler Quadro. That came back with results such as the Quadro FX K600, K4000 etc. I then browsed the GI2Shaders subkeys (folders) until I found the folder with those Quadro cards in them. All is now working fine!

  • Grigore Mihai (GGG)
    Grigore Mihai (GGG) over 1 year ago

    Windows 7 64bit /w GeForce GT525M , activated Realview in SW2014, following steps Leucetius wrote, with the mentions Plecostomus Prime wrote.

    1.) Open up the registry editor (Start Button -> Run... -> "regedit")

    2.) Navigate to "HKEY_CURRENT_USER\Software\SolidWorks\SOLIDWORKS 2015\Performance\Graphics\Hardware\Current"

    3.) On the right side doubleclick on "Renderer"

    4.) copy (Ctrl+C) the Value

    5.) Navigate to "HKEY_CURRENT_USER\Software\SolidWorks\SOLIDWORKS 2015\Performance\Graphics\Hardware\Gl2Shaders\NV40"

    6.) On the left side (the treeview) rightclick on "NV40" and choose "New / Key"

    7.) Rename the new key with the copied value (Ctrl+V)

    8.) Click another Key and back to your newly created to make sure you are editing the right values. The right side should be empty but an entry (Default) whose data is "value not set"

    9.) rightclick in the right side and create "New / DWORD (32-bit) Value"

    10.) Rename the DWORD to "Workarounds" and, after that, doublecklick it

    11.) Leave the "Base" to "Hexadecimal" and enter 30008 into the field "Value data"

    Opened SW and did nothing, Realview was on by itself.

  • Joseph McDonald
    Joseph McDonald about 2 years ago

    I have a GTX 970m in a laptop and I followed these instructions except in the last few steps where you add the registry I selected the NV40 folder. I did everything else the same and it works flawlessly!!

  • Jhazmin Raya Quispe
    Jhazmin Raya Quispe over 1 year ago

    Thanks so much, My graphic card is GeForce GTX 960M and worked in NV40

  • Will McFarrell
    Will McFarrell about 2 years ago

    Many thanks for the great tutorial Leucetius, Realview is working just great with an AMD Radeon HD 5450 card.

  • Voibor
    Voibor about 1 year ago

    Быстрый способ включения "Real view..":
    1. Создать текстовый файл :

    Windows Registry Editor Version 5.00

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2015\Performance\Graphics\Hardware\Gl2Shaders\NV40\GeForce GTX 970M]
    "Workarounds"=dword:00000008
    [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2015\Performance\Graphics\Hardware\NVIDIA Corporation\GeForce\V001_FG_K513011241_X513011241_V715109734]
    "Workarounds"=dword:02001001

    GeForce GTX 970M - модель видеокарты

    2. Изменить расширение текстового файла с "*.txt" на "*.reg"
    3. Запустить файл

    Attachments

    NVidia 2015.reg, 754 Bytes
    Download
  • Nino
    Nino about 1 year ago

    Now its working... thanks guys..

  • Sten Rasmussen
    Sten Rasmussen 6 months ago

    It worked for me as well :o). Did exactly like described in the first post, but since my card is a GTX 970 (Maxwell architecture, also used in Quadro M4000 & M5000) i used the NV40 folder (which contains M4000 & M5000 cards) like described by others. Woohoo, things looks so much better now! ;o) Thanks for sharing this cool workaround.

  • Jesus Meneses
    Jesus Meneses about 2 years ago

    AMD Radeon HD 6670 and RealView working just fine

  • asymptote
    asymptote almost 2 years ago

    Leucetius you Rock!...works a treat.

  • Daniel E
    Daniel E almost 2 years ago

    I'm hoping someone in this thread can help me. I'm running SW 2016 in Windows 10 using a GeForce GTX 870M/PCIe/SSE2. I've followed the instructions and it's not working for me. I see that the suggested hexidecimal values are ones that already exist in the list for other video cards, so I've gone through the list and tried every one. No luck. Are there any other settings that could be wrong in my system that might cause this not to work? Is it just a matter of entering the correct hexidecimal value?

  • Agustin Benitez
    Agustin Benitez over 1 year ago

    Awesome!!!!! Thanks a lot!!! This worked perfectly on my macbook pro retina 15" with SW2016. I'm running Sw on Windows 10 via bootcamp.

  • tbanks engineering
    tbanks engineering over 1 year ago

    The workaround using Plecostomus Prime's post worked perfectly for my workstation with SW 2016 with a NVIDIA GeForce GTX 780 Ti graphics card.

    Already applied to the change to all my coworker's workstations too! :)

    Thanks!

  • Sam Marru Mardjuki
    Sam Marru Mardjuki over 1 year ago

    i'm using AMD Radeon R5 M230, and i followed each steps that Leucetius mentioned, and 'BAMM' its working fine on my SolidWorks 2016, and now i can enjoy using RealView. thank you so much.. ;D

  • Jared Mankins
    Jared Mankins over 1 year ago

    Does it matter if I have a 64 bit operating system? I have an NVIDIA GeForce GT 730 and I can't get it to work. Also, when I lookup the video cards name, I'm getting "GDI Generic" not the name of the card like everyone else has gotten. Any help?

  • Jared Mankins
    Jared Mankins over 1 year ago

    Does it matter if I have a 64 bit operating system? I have an NVIDIA GeForce GT 730 and I can't get it to work. Also, when I lookup the video cards name, I'm getting "GDI Generic" not the name of the card like everyone else has gotten. Any help?

  • Jamal Husen
    Jamal Husen over 1 year ago

    Thank You so much i have GeForce 820M/PCIe/SSE2 and i creat a key in NV40 and i got Real View :D

  • BH QUANG
    BH QUANG over 1 year ago

    For me, step 5 & 6, i selected Intel, since my laptop is built by intel graphic HD 4000. Then it worked perfectly. Many thanks.

  • The LeadeR
    The LeadeR over 1 year ago

    it worked! Awesome ! thanks all friends! and special thx forLeucetius

  • AHTAHAC
    AHTAHAC about 1 year ago

    It worked withSolidWorks 2016 and 2017 beta on Win 10 (64Bit) , graphic card Geforce GTX 970

  • ks negi
    ks negi about 1 year ago

    RealView works fine on the NVidia geforce M820 video adapter. I made the key in the NV40 folder (step 5 and 6) on my laptop hp-15r007tx
    thanks a lot

  • Alexander Willer
    Alexander Willer about 1 year ago

    I have a geforce GTX1070 and I used the folder NV40 and it worked perfectly.
    I also noticed that ,y overall performance in solidworks changed to the better

    keep the good works up

    thanks

  • Daniel E
    Daniel E 12 months ago

    "I got this working and I thought I would describe it here so it might help someone else. The hexidecimal value for mine was 70408. The missing link that no one else described here, that made it fork for me was this....Open SW (don't open a file) and go to the options->performance then uncheck the box "Use software OpenGL". This is what was preventing it from working when I originally made my post"

    The above quote is something I posted earlier this year but was buried as a comment to my original post. I thought I would re-post in a main comment so this info might be easier to find.

    I just installed SW 2017. I had to redo this to get my real view working on the new installation.

  • Karl Andre Tafjord
    Karl Andre Tafjord 12 months ago

    Anyone here with a Titan X Pascal got it working? I have tried every conceivable workaround value I've found, codes that have been confirmed working on 1060/1070/1080's doesn't work.
    The Quadro P5000/P6000 cards use 31408, and those don't work.
    The weird thing is that the Realview option is not greyed out, but it doesn't render. Realview 'activates' no matter what value I put in the Workarounds DWORD. On my knees here :)

  • jeremy
    jeremy 11 months ago

    Solidworks 2017, Windows 10, Nvidia GeForce 8800 GT, I used the NV40 folder and followed all of Leucetius's instructions and worked like a charm. Thanks

  • Heather Lewis
    Heather Lewis 9 months ago

    This worked for my Intel(R) HD Graphics 520.

  • adidoro adidoro
    adidoro adidoro 9 months ago

    Worked! My card is AMD Radeon R5 Graphics (AMD Radeon (TM) R7 M340) with 30008 value. Thank you!

  • Santi
    Santi 8 months ago

    Thank you very much.

    The NV40 folder is the key because with the first solution it didn't works.

  • Phuc Nguyen
    Phuc Nguyen about 1 month ago

    Solidworks 2016, Win10 4bit, NVIDIA NVS 5400M, realview graphics didn't work please help me!

  • Ilya Meylikhov
    Ilya Meylikhov about 2 years ago

    Hey! I would like to confirm that RealView works fine on the NVidia GTX 660 video adapter. I made the key in the NV40 folder (step 5 and 6) according to Plecostomus Prime comment.

  • krunal gajjar
    krunal gajjar about 2 years ago

    I using get force 210 please give key

  • Mr Joker
    Mr Joker almost 2 years ago

    Please help me about AMD Redeon 6900?

  • djamel
    djamel about 2 years ago

    What about Intel(R) HD Graphics Family?
    I have the same problem, but with intel card, what is the workaounds reg key

  • john fall
    john fall over 2 years ago

    Solidworks realview only works with Quadro or Firepro cards

Add your answer to: "How I can activate "real view graphics" in my "Solidworks 2015 X 64 Bit,SP2" ? My operating system is Windows 7 X 64 Bit ,SP1 and my graphics card is AMD Radeon HD 7500M/7600M Series . I have already tried "RealHack 3.9.1" but it is not working. :( "

Save Cancel