How to active solidworks realview graphics?

hi,
I like to know how to active solidworks real view graphics?
Thank you.

Answer
 
Comments 0

20 Answers

Hi Nicolas, I had same problem and I solved it.
This is pretty old topic, but I write solution for this anyway if someone needs it in future.

I'm not sure how this work with AMD cards, but with all Nvidia Geforce cards this should work.

1.Open the registry (Run -> regedit)
2.Navigate to "HKEY_CURRENT_USER>SOFTWARE>Solidworks>SOLIDWORKS 2015>Performance>Graphics>Hardware>Current"
3. Double click on the "Renderer" key and copy the text under "Value Data". For example, for the GTX 770 mine was "GeForce GTX 770/PCIe/SSE2"
4.Navigate to "HKEY_CURRENT_USERSOFTWARE>Solidworks>SOLIDWORKS 2015>Performance>Graphics>Gl2Shaders>NV40"
5.Right-click on the NV40 folder on the left pane and select "New -> Key"
6.Rename the new key with what was copied in step #3
7.The only key in this folder should be a "(Default)" key
8.Right-click on the right pane and select "New -> DWORD (32-bit) Value"
9.Name this new key "Workarounds"
10.Double-click on the "Workarounds" key and enter the value "30408". You should be in Hexadecimal mode.
11.RealView should now be available. If it is not, try setting the value in step #10 to "31408" or "30008"

hope this works for you.

 
Comments 6

Teemu and John have a right. When you don't have a certificate graphics card :AMD Fire Pro or NVIDIA Quadro SolidWorks don't have this option.

But is the one way to do this :)

 
Comments 0

see attached Jpeg, NB realview graphics will not show if you do not have a suitable graphics card

 
Comments 1

Propably realview graphics is not supported by your graphic card if you can't use it at SolidWorks.
More info here:
http://www.solidworks.com/sw/support/videocardtesting.html

 
Comments 0

If you work on mac/parallels - here you find the registry-patches regarding your used Solidworks version: http://kb.parallels.com/de/122790 find it attached below for Version 2016. Cheers!

 
Comments 1

There is a third party -not officially supported- application that enables realview graphics in SW2010-2015 called realhack (v3.9.1 for up to SW2015) you can google it and give i t a try ;) If i recall correct most other software, including Catia, Inventor, TopSolid 7 etc. support realview-like graphics with any card. It is just a marketing nvidia-solidworks thing :)

 
Comments 0

You can just edit the register to enable it in almost every nvidia or ati card ... What card do you have?

 
Comments 0

and how would you go about editing the register? I have an Nvidia 780 card

 
Comments 0

thank you Antti Nieminen its very helpfull

 
Comments 0

Just wanted to say thank you so much Antti Nieminen it works perfectly now :)

 
Comments 0

hye, i just do this and it work correctly
many thanks

 
Comments 0

I have AMD Radeon (TM) HD graphics card in my system..I have tried all the tricks like real hack and regedit..
But didn't work,plz help me out guys

 
Comments 0

i have Intel(R) HD Graphics 3000
plz help me

 
Comments 0

I'm working on AMD Radeon R5 M335 but not able to enable realview with above steps please help!!

 
Comments 0

Can confirm works on Geforce770, thank you Antti Nieminen

 
Comments 0

Hello,
Sorry for my english .. I'm from Germany.
I have modified the already known RealView hack.
I call it version 5.0.1
It thus works for the SW version 2018

Have fun with it !
Example image without RealView https://www1.xup.in/exec/ximg.php?fid=18127990
Example picture with RealView https://www1.xup.in/exec/ximg.php?fid=13210535

 
Comments 0

hello there is many post for this problem
i got it one day and find here the solution
very easy to resolve this
follow the explication
and enjoy

this is the post from Antti Nieminen

1.Open the registry (Run -> regedit)

2.Navigate to "HKEY_CURRENT_USER>SOFTWARE>Solidworks>SOLIDWORKS 2015>Performance>Graphics>Hardware>Current"

3. Double click on the "Renderer" key and copy the text under "Value Data". For example, for the GTX 770 mine was "GeForce GTX 770/PCIe/SSE2"

4.Navigate to "HKEY_CURRENT_USERSOFTWARE>Solidworks>SOLIDWORKS 2015>Performance>Graphics>Gl2Shaders>NV40"

5.Right-click on the NV40 folder on the left pane and select "New -> Key"
6.Rename the new key with what was copied in step #3

7.The only key in this folder should be a "(Default)" key

8.Right-click on the right pane and select "New -> DWORD (32-bit) Value"

9.Name this new key "Workarounds"

10.Double-click on the "Workarounds" key and enter the value "30408". You should be in Hexadecimal mode.

11.RealView should now be available. If it is not, try setting the value in step #10 to "31408" or "30008"

 
Comments 0

hello there is many post for this problem
i got it one day and find here the solution
very easy to resolve this
follow the explication
and enjoy

this is the post from Antti Nieminen

1.Open the registry (Run -> regedit)

2.Navigate to "HKEY_CURRENT_USER>SOFTWARE>Solidworks>SOLIDWORKS 2015>Performance>Graphics>Hardware>Current"

3. Double click on the "Renderer" key and copy the text under "Value Data". For example, for the GTX 770 mine was "GeForce GTX 770/PCIe/SSE2"

4.Navigate to "HKEY_CURRENT_USERSOFTWARE>Solidworks>SOLIDWORKS 2015>Performance>Graphics>Gl2Shaders>NV40"

5.Right-click on the NV40 folder on the left pane and select "New -> Key"
6.Rename the new key with what was copied in step #3

7.The only key in this folder should be a "(Default)" key

8.Right-click on the right pane and select "New -> DWORD (32-bit) Value"

9.Name this new key "Workarounds"

10.Double-click on the "Workarounds" key and enter the value "30408". You should be in Hexadecimal mode.

11.RealView should now be available. If it is not, try setting the value in step #10 to "31408" or "30008"

 
Comments 0