How to fix a broken Surface Blend?

Ever since I tried the surface blend option in Rhino, it made me sick with artefacts, self-intersecting geometry and rarely a traceable error in my model that I could improve upon in order to fix the blend.

Now, does anyone here know a couple of 'golden rules' when it comes to blending surfaces? I know a few things already: don't put the two edges too close to eachother, dont make the profile of the edges too sharp and make sure that the profile is planar, in order to maximise the chance on success.

I would so totally love to hear your recommendations and 'golden design rules'! For inspiration, I have added a couple of screenshots from typical blend-fails I have run into...

Upon request, I have added a model of my 17 inch rim, which has faulty surface blends connecting the spokes to the rim wall. I have deleted one of the blends to reveal the profiles. This, of course, is just 'an example' of what could go wrong...

Answer
 
Comments 4

4 Answers

I'm just throwing some ideas in here, as I still have problems like that. Make sure the edges run/selected in the same direction. Try lofting two edges and see the result from selecting parallel edges and opposites. You get that horrible twisted look. Watch out for surfaces you have edited and then try to blend, they may not be a continuos surface. I sometimes cheat and create lines to loft between to get a result where things are going wrong, then patch this to the model. My requirement is usually for a watertight model, so how I achieve it isn't the issue for me. Others have different standards/requirements, your mileage may vary with these suggestions.

Most important, just break your model down into simple components and work on just that bit to try and figure out whats happening, you can always graft it into the full model if thats the only way.

Just play, and learn.

 
Comments 0

Surface blend is a great feature, an easy way to go, it works great but very often I would not use it because it may give you some problem of recognition when exporting in other format, like Solidworks for instance, or similar problems like you get here.
I looked at your model.
Ok, I don't know if that will help to do what you want but here’s an alternative that should work and get the job done. But obviously will take a little more tricks. You need to create new nurbs on each of the surfaces you want to blend at needed reference points where the curvature changes and then blend each of them the way you want using one of the blend curve tool and use those new nurbs to create a surface from.
Here’s what I did ( if you look at the image in attachment)
First: using the extract isocurve tool, you create 4 new nurbs on each of the surface.
(look at Dot #1 on the jpeg)
Second: using the Adjustable Curve Blend tool, you blend the curves together and ajust them with the handles to get the curvature you want at each location.
(look at Dot #2 on the jpegs)

Third: using the Surface from Network of Curves, you select each new curves and the edges of the surfaces you want to blend and select the tangent option in the option box.
(look at dot #3 on the jpegs)
Usually I created all needed nurbs prior to build any surface with minimum of control points and I make sure each one is smooth and even along the object. It takes a little more time at the beginning but will give a more precise result. There are just so many ways to build a model and there is always a way around when one tool doesn't give the expected result. I hope that helps.
Great model by the way.
Total time to fix each: 5 min.
I don't know if that helps but that's one solution, and there may be others.

 
Comments 0

Could be also a problem with oldest Rhino versions, try with Rhino 5.

 
Comments 0