How to get rid of this dimension glitch?

Regardless of entering new sketch or editing existing ones, the default cursor is always smart dimension, and I cant select entities unless I have a selection filter.

Any dimension I place with this default cursor is also invisible.
Tried registry edits, restarting solidworks and my computer.
Can not seem to solve this problem.

Basically the plain selection cursor has somehow turned to the dimension cursor, and the dimensions I give are not visible for some reason. Sometimes
my mouse instead of being a normal mouse cursor, is a mouse icon with a locked right-button.

Answer
 
Comments 0

5 Answers

Could you post a simple part that you had this happen in? Then we can see if it looks the same to us.
Maybe post a screenshot of what it looks like on your end as well. Then we can see how it differs.

Without more to go on, I'd call it a "graphics issue". Try restarting SolidWotks, then with no files open go to:
tools - options - performance
Turn on the option for Software OpenGL
Restart solidworks, and see if it is any different.

 
Comments 2

It looks normal to me, see this screenshot.
It is odd to have dimension names showing, but I guess you might be using them?

Try restarting solidworks, don't open anything, and see if that performance option is still greyed out.

 
Comments 0

No I am not using dimension names. Yes that performance option is not grayed out when no file is open. but selecting that option doesn't solve the problem.

 
Comments 0

Two similar kind of question have been posted in SOLIDWORKS forum earlier. And seems like Uninstalling ,then reinstalling SOLIODWORKS is the only solution. But I want to know if anything else is there that can be done to solve this problem. That is why haven't uninstalled it yet, and still looking for an answer.

 
Comments 0