ashok

how to use 'set representation to' option in creo

Question by ashok

please show how to use 'set representation to' option in part modeling

Answer
 
Comments 0

2 Answers

Tyler Upchurch
Answered on 29 Aug, 2015 04:12 PM

I realize this is old, but here's my answer. Gokul and I both commented on another similar question, and I gave the most detailed answer I could. So I'm copy-pasting that answer here. The other question dealt with Excluding a Part/Feature, but it's the same process for whichever representation option you want. Don't know if you need all of this, but here it is:
Gokul Arasu's answer is partially correct, but you will probably need to use "Combined States" to get the result you want. I realize this question is over 2 years old, but I just learned how to do this, so I thought I'd share my knowledge.
In the view manager, you can create Simplified Reps, as Gokul was saying. You can either use the right click menu in the feature tree to Set Representation of Parts and Features which you want to hide to Exclude and then save as a new rep, or you can create a new Rep and define it to exclude those Parts/Features. If you want to add Parts/Features and have them be excluded by default, the best practice would be to redefine the Default Rep (or some new rep that you create) to exclude everything by default, then manually select all the Parts/Features that you wish to include (in the Default Rep definition window within the view manager). Once you've highlighted the desired Parts/Features, right click and select "Set Representation To" and click "Master" or whichever User Defined Rep you desire. This will cause any new Parts/Features to be excluded from this rep by default unless you redefine the rep and manually set representation to Master or some other rep. For large assemblies with several nested subassemblies, you'll need to repeat this process for the Default Rep of each subassembly.
But here is the trick. To get the reps to display the way you want, with the excluded Parts/Features actually excluded, you need to use Combined States and a certain configuration option. Combined States are found in the "All" tab of the View Manager. The Default Combined State actually displays the Master Rep, not the Default Rep. Confusing, I know. So what you do is this: for each Assembly and Subassembly that contains the Parts/Features that you wish to leave excluded by default, you define a new Combined State that displays the Simplified Rep you defined to exclude those Parts/Features. The way I do it, is I name the Combined State the exact same name as the Simplified Rep which it references. And I use these same names for each Part, Subassembly, and Assembly that includes the excluded Parts/Features. So you have to do this for every single layer of the assembly, from the Part with the excluded feature or the Subassembly with the excluded Part, and each parent Subassembly containing that Part/Subassembly, all the way up to the top level Assembly.
Then, the final step that will cause the desired Parts/Features to be excluded every time you open the Assembly, in every new session of Creo, is to change the following config option to open the desired rep by default:
open_simplified_rep_by_default
I have this set to "default rep," but you should be able to change it to whichever Simplified Rep you desire. If that Rep doesn't exist for some Part or Assembly, the Default Rep will open, by default, lol. Make sure to export this config option to your config.pro file in the same directory where the Assembly/Part is saved so that it's always applied.
If this is all too confusing, there are lots of great YouTube tutorials that explain it better than a comment on GRABCAD can. The trouble is that you probably have to watch tons of videos to get the full picture. I can try to clarify if necessary.

 
Comments 2
Gokul Arasu
Answered on 20 Sep, 2014 01:15 PM

Select the features in the model tree which you want to exclude from the graphic window. Right click ---> Set Representation to ---> Exclude. The child objects will also be excluded.

 
Comments 0