Is it a common SolidWorks 2012 drawing error for the millimeter dimension defaulting to a zero decimal place and not allowing a over ride?

Im trying to set up drafting standards at work, however I am not able to get solidworks 2012 to call out a .00 decimal places for any millimeter dimension. If I was trying to call out a two millimeter hole it would read 2.
I would like it to read 2.00
I have tryed all of the settings it also will not override. is this a common solidworks 2012 problem

Answer
 
Comments 0

4 Answers

Options -> Document propetries-> Dimensions and you must find Trailin zeroes, change to "show"

 
Comments 0

It will always show 2 for a 2.000 dimension. Try increasing the dimension to 2.01 and see if it shows it as 2.01. If yes, then, it's all ok. I think you can set it to show callouts with two decimals, but I never investigated
how to set it up.

edit: Lukasz gave the answer you are looking for ;)

 
Comments 0

As per ANSI drafting standard, trailing zeros for metric dimensions are prohibited. You should turn this option on only for imperial dimensioning.

 
Comments 0

Tools>options>annotations (change "smart" to "show")
Tools>options>dimensions (change "smart" to "show")

If you don't change the setting in both menus the zeros won't show.

 
Comments 0