Why are my circles not smooth in SolidWorks?

It seems that when I extrude a circle, it has jagged edges. I don't remember it always being like this. Anyone know how to fix this? I have an example image attached.

Answer
 
Comments 0

3 Answers

They are smooth but the image quality could be adjusted , go into options and set the display quality

 
Comments 0

Like Julian said, it's actually a perfectly smooth circle. There are just fewer points in the mesh being used to represent it on screen. This feature is very useful when dealing with huge files that would otherwise slow down your computer.

 
Comments 0

you can change the quality of the circle via the options menu. Then choose document properties and the image quality. There you can pull the slider to the right to make circles more round, but be carefull that perfect round circles take much longer regenerating times

 
Comments 0