Why does cut in Inventor 2023 not work?

In an Inventor part, I am trying to cut an object using the Extrude tool. But when I cut, only a part of it gets cut. The rest is still the same.

Any help is appreciated!

*Edit
Thanks for answering so quickly! I tried to make my part into one whole body without much luck. I will share my part file if that would help analyze the problem

Accepted answer

Starting with the DeleteFace1 feature you have turned the entire back half into surface features. You never turned any of that back into a solid so you can't use a simple extrude cut to modify it.

Like I mentioned on another similar question yesterday with an identical problem:
"I see nothing on this model that required the use of any surfacing operations. So most of the times you used the deleteface command were unnecessary."

The deleteface command essentially turns a solid into a feature with very limited editing capabilities. It is seldom needed and in all the years of doing 3D solid modeling with Inventor I have never once used it. If you use it, you need to be aware that you may need to stitch the surfaces back together at some point. That can be quite difficult the more edits you make and at some point may seem impossible. Unless you are actually doing some true surfacing commands I see almost no reason to ever use the DeleteFace command. You haven't used any surfacing commands.

My best suggestion for you and many others: Do not use the DeletFace command.

You have many sketches with totally unconstrained elements. This is a dangerous practice. Every time you create a sketch, get into the habit of fully constraining every element until everything turns black. Preferably that means using a more little logic than just putting a lock on everything but that's better than nothing. Do this before consuming the sketch into a feature and moving on.


1 Other answer

About the only way this can happen is if you have multiple solid bodies and you are only cutting a single solid body.