How to make an imported subassembly (STEP file) flexible?

I imported an adjustable angle bracket to install and it is not free to move when I try to adjust the angle. The Feature manager tree was not working in this case. Please advise

Answer
 
Comments 0

2 Answers

The Step file imports as a PART file with three bodies.
If you want motion, and mates, this needs to be an ASSEMBLY file.

- Save each of the individual part bodies off as individual part files.
- Create an assembly
- Add parts, and mates to get the desired motion.

Yup. Deleting the unwanted parts and then saving the remaining one out as a new part is one way to go about the process.

A few other options are:
1. You could make different configurations of the part. In each one you'd suppress the unwanted parts (not delete, suppress them).

2. You can also right click on Solid Bodies in the feature tree and choose Save Bodies. This allows each body to be saved as a separate part.

I'd normally use option 2, but it really depends on the situation.

 
Comments 3

You are doing nothing wrong. Mates are not exported when translating data into the neutral formats such as step. That is how the translators work.

When you import a step file there is no way to import the mates that were originally created.

You will need to add them back in.

See FredSWUG answer a similar question here:
https://grabcad.com/questions/is-there-any-way-to-keep-mates-when-importing-a-step-file-in-solidworks

 
Comments 3