Ask and answer engineering questions

Learn from millions of experts

Missing feed

Problem installing Solidworks 2013 x64 edition sp04

By Andreas Daving on 11 Oct 11:25 13 answers 5 comments

I have been struggeling with installing Solidworks 2013 sp04 64-bit on my laptop after I did a recovery of the computer (re-installing windows 7). I have ran windows update and checked all drivers that everything is up to date.

My first problem is that the install manager will not work. When I open the setup the manager starts, but there is only a clean window with the usual "solidworks" banner on top. I have tried different solutions by google'ing the problem, but nothing seems to help. Trying to reset internet explorer and set to default browser and etc..

But I can walk around this by starting the setup file in the folder swwi > data, and the setup starts and seems to work just fine until the very end where it says "the wizard was interrupted before solidworks 2013 x64 edition sp04"... It even created a desktop icon and everything before this message and after that it just deletes all solidworks files..

I tried to install the 2012 edition, with success. That is working perfectly, but since Im using solidworks for a school project and everyone else is using 2013, I cant use 2012..

Hopefully you understand my problem, and if anyone have experienced similar problems let me know!
I think its just wierd that 2012 works fine, and 2013 not at all.. Is there some major update in 2013 that is causing these problems?

Thank you for all answers!

Best regards
Andreas.

13 answers

  • saad mehmood
    saad mehmood about 4 years ago

    try to restore the data from backup that can be useful try it after that try to install s.w

  • Andreas Daving
    Andreas Daving about 4 years ago

    Thanks for response, Saad!

    But how do I know what is useful or not..?
    I got a tip about checking the install log file to determine what's causing the error. But I'm not very experienced with these kind of problems so I'm kind of shooting in the dark if you know what I mean.
    Anyone know exactly where to find these install log files in windows 7, and what to look for regarding Solidworks installation?
    Just worried to make things worse by messing up things I dont have a clue about, hehe.

  • Andreas Daving
    Andreas Daving about 4 years ago

    Tried to follow the steps, but unfortunately it did not make any change..

    I have now localized the install log file, and seems to be an error in "RegVal.exe". Please see the added file to read the complete log file.

    What does this error accually mean? And is it a quick fix or complicated?

    Thanks.

    Attachments

    sldIMLog_20130-40400-1100_00011.txt, 97.6 KB
    Download
  • jissi
    jissi about 4 years ago

    try this :

    unistall SW2013

    download ccleaner from piriform webpage
    here is the link :
    http://www.piriform.com/ccleaner/download/standard

    once installed, run it, then on the left side there is an icon named register or something like this.
    click on it
    check for errors and fix errors (by deleting missing entries)
    go in the folder where solidworks had been installed and make sure that no file still exist : delete folder.

    To finish, run your illegal version of SW2013 following ALL the instructions, copy the files in the destination folder of the install.

    Run SW

    Have fun

  • Andreas Daving
    Andreas Daving about 4 years ago

    Still problem with SW2013 on my laptop..
    Maybe just buy a new laptop...? Hah..

    Google'd regval.exe error and seems that its a quite common problem. Found some programs that automatically fix regval.exe (Advanced Fix 2013), but thats a program that you need to buy before use. Is it worth a try, or is it just the same as ccleaner?

  • jissi
    jissi about 4 years ago

    try illegal version XP

  • jissi
    jissi about 4 years ago

    When the legal way is not sufficient, there is always another way...

  • joshua anderson
    joshua anderson almost 4 years ago

    OK, This sounds like a problem That I had previously ran into with SW2008, SW2009, pretty much anything after SW2007.

    If it is the problem I am thinking about then it is a Windows problem not a solidworks problem. It has to do with the version of Microsoft Visual C/C++ Redistributable that is currently installed in windows. Check to see if it is the latest version. If it's not, then download and install the latest version and try again.

    Here is a somewhat crude roadmap of what is happening.

    SW installation manager comes to the point where it installs Visual C/C++
    Redistributable Ver 4.0. If your laptop has Ver 2.0 installed, but not ver 3.0, the install manager will not have the proper library to incorporate ver 4.0 into. (This may be what the VBA warning towards the end of the log is all about) Upon failure to find the previous consecutive version it skips the installation of Visual C/C++ which is what links the solidworks library to the windows library. This is the last thing it does on the install, so if it fails it will create exactly the situation that you are describing. Check microsofts website about this problem. They may have some more info.

    Good luck.

  • aamir hasssan
    aamir hasssan over 3 years ago

    Try using the setup from swwii>>Data>>solidworks.exe
    It worked for me on Win 7 SP1.

  • Yeşua Han
    Yeşua Han over 2 years ago

    hi guys...SW2013 problem common0.cab file is corrupted or not found :( also install execute not found...please help me

Add your answer to: "Problem installing Solidworks 2013 x64 edition sp04"

Save Cancel