Brendan A. Creaner

Solidworks complains "No OpenGL acceleration' when started

Question by Brendan A. Creaner

I'm running Solidworks 2014 on a Toshiba Satellite laptop with a Mobile Intel GMA4500M graphics adapter. When I open Windows-10 'Settings', it says it has the latest driver for the graphics card - but actually Intel is not updating this adapter with new software. The OpenGL website doesn't seem to have a download for Windows-10 yet - so what can I do? Can I afford to ignore this warning from Solidworks?

Answer
 
Comments 1

5 Answers

ahmed sami
Answered on 30 Jan, 2016 06:52 PM

open Regedit
- open HKEY_CURRENT_USER, SOFTWARE, search for solidworks change name to solidworks-old
please close solidworks before make this change.

 
Comments 0
Brendan A. Creaner
Answered on 28 Oct, 2015 09:05 PM

trinityscsp said go back to Windows-7, as SW-14 does not support Windows-10. OK..............!

Right now I have a minor problem with 'imperfect' graphics - it's nothing compared to the grief I would have trying to revert my Operation System to an earlier version! I guess I'll just have to accept the present status.

 
Comments 0
FredSWUG
Answered on 7 Nov, 2015 05:53 PM

Try this;
Open SolidWorks, but do not open any files. Go to Tools - Options - System Options - Performance and turn on the check box for Use Software OpenGL.
The performance may be a little slower, but if SolidWorks is not making much use of your graphics card, at least this should make the error message go away.

 
Comments 0
Brendan A. Creaner
Answered on 9 Nov, 2015 02:14 PM

Thanks FredSWUG, that seemed like a great idea - but when I opened Tools\Options\System Options\Performance I found the box for 'Use software OpenGL' already ticked - but the whole line was 'greyed-out'!! i.e. I could not change it either way.
It may not be relevant/important, at all, but the complaint about lack of OpenGL acceleration doesn't appear until AFTER I try to open an individual model - NOT there if I close down all models before closing Solidworks.

 
Comments 0
FredSWUG
Answered on 1 Feb, 2016 01:23 PM

Brendan,
The checkbox for the OpenGL option will be greyed out if you have any files open in SolidWorks. Close SolidWorks, re-start SolidWorks, Go directly to the OpenGL option, see if it is no longer greyed out.

If it is checked now, you should be able to uncheck it. I have seen some systems have it unchecked, and always greyed out, but that was many years ago on hardware that was not designed to run SolidWorks.

 
Comments 0