Closing surfaces

Hi, guys, I'd really appreciate if you could help me figure this thing out:

I'm having a problem with this CATIA model. The thing is, I can't close the surfaces in order to thicken them, and create a new body, I've tried heal command and such things, having no success. I think I've run out of ideas, I even thought of creating a different body and combine them with a boolean operation.

What I did to create the two surfaces I'm trying to thicken was, in one hand, drawing circles and then connect them with a Pline, then I swept them with the two guiding lines option as you can see in the image attached. And, in the other hand, I just drew a quarter of a sphere.

Hope you guys are okay there, Thank you so much in advance.

Answer
 
Comments 0

12 Answers

Blend is not good option for creating this type of parts. Keep sweep or multi section surface.

 
Comments 0

Here is the solutions parts.

Espiral_zgr2 --> sweep method (i prefer this generally)

Espiral_zgr3 --> multi section surface method (i prefer this sometimes)

 
Comments 0

if you share unmodified model, maybe we can help. Pictures are not enough clear.

 
Comments 0

Sorry, you're right, my bad. I attach the model, but I'm afraid to tell you that I've already modified it this morining.
What I did now was creating the endings by parts as you can see in the model, which actually improved the solution, but I still get some gaps when thinckening it. I remember CATIA displaying a message, but I don't really remember the exact words it was something like the model might look kind of akward when thinkening the surfaces".
I think this solution is a good one, but no the right one because when runing a FEA at this element of the whole body I'm working on, one of the two ends tend to split up, as you can see in the image attached.

Hope this helps to clarify the problem I'm having.
Thank you so much for the attention.

 
Comments 0

Thank you so much for your supporting! Let me check it more carefully at home in order to verify its performance during the FEA.

Also, if possible, I would really appreciate if you could take a look at this other method I tried. What I did it was blend the surface by parts, but when I get to the last segment I find no way to blend it.

I want to thank you again for your supporting.

 
Comments 0

I see, maybe that's the reason why I couldn't finish the model. So how is it possible to keep the tangency restriction between surfaces if not blending them? I read somewhere that it is possible to create the surface itself with such characteristic, but I'm not sure given that its the first time I use GSD module.

Again, thank you for the advice.

 
Comments 0

i will share tonight 2 model with tancency. One is for Sweep and other one for Multifuction support.

 
Comments 0

Alright, looking forward to take a look at them,
Thank you.

 
Comments 0

I now understand why it is better sweep or multi-section surface command. But what happens if we had, maybe, a non-tangent surface when creating a multi-section surface (I know this sounds kinda dumb, but I don't know, sometimes it happens to me that the two surfaces really look tangent to each other but actually they aren't, and CATIA displays a message telling me something doesn't fully lay on a surface or something like that(?))?

I'd like to share with you the school project I'm currently working on since you've really helped here (I'm really thankful by the way), it's not the big deal and it's not finished yet, but I'm almost there. Still figuring out and working on some details.

Again, thank you for the coaching.

 
Comments 0

Best way for checking tangency is join command. If you use join after some steps and check tangency options is on, you will not have any tangency problem.

Design language and methods are situations that you can earn experience by doing mistakes and taking lessons.

 
Comments 0

hello friends,
my client was send some iges file to create solid. i try to fix that problem on catia v5. but i cant create solid. because major problem is surface gap is there. but i cant find out surface gaps.
And also i try to fix this problem on transmagic software but it cant rectified. what can i do now friends... can you any one help me guys please....

 
Comments 1