Why does pressing the enter key delete tutorial without prompt at any point during making it?

This has happened so many times now I have just stopped posting tutorials. I have 7 in waiting to get posted too.

Even on the first screen pressing enter to move down a line deletes the tutorial. Only on the very first screen does it prompt a message. If you are anywhere beyond that the tutorial and any work done is just lost.

Saving does not help, since it deletes the save.

This takes place in Internet explorer, chrome, firefox and edge.

In the included screenshot I just kept pressing enter to generate the message.

2 Answers

I have had the same problem. Adding a tutorial can be an annoying process. in my view GrabCad should rethink and redesign the whole tutorial module. They should, along with cleaning up the code to fix this bug, look at making tutorials much more useful, the could add a function to enable the attachment of pdf files to a tutorial to enable a hard copy to be printed out for future reference.

But as underneath it all GrabCad is a business, so spending time and effort on this module may not be worth the effort. The standards of tutorials posted range from a load of rubbish and a waste of space, to some that are fairly useful. The "badge and points system" for posting tutorials encourages quantity and not quality. With the large number of tutorials on youtube are tutorials on GrabCad of much point.

I've had the Tutorial system eat one of my tutorials, but I'm not sure of the reason, or cause.

I tried creating a new tutorial tonight, and it works fine when pressing enter. It just starts a new line as expected. I created multiple pages, with multiple lines of text.

It is good to see you've already tried all the common browsers. The next thing may be to try disabling any add-ons to see if they cause the problem.

As an alternative, don't write the tutorial in GrabCAD. Create it in a text editor (like Word), then paste it into GrabCAD.