How to solve Reference Problem in SolidWorks "because of the current setting, the reference will be automatically broken"

Hi guys!

I'm not sure how to put this, but I seem to have made any setting change by mistake.. Cause when I want to create a new part in the assembly (or editing an existing part) and want to make a reference to another part it says:

"because of the current setting, the reference will be automatically broken."

I'm quite experienced with Solidworks, but now I don't have a clue what to do.. Hehe.

Currently making a car for a school project which got to be done by monday. Allmost done, but suddenly this appears..

Thanks for all tips and help!

/ Andreas

Answer
 
Comments 0

3 Answers

If you can't seem to fix the problem I would restore your SW back to original settings and hopefully that will fix your problem...

 
Comments 0

Almost every problem in solidworks is fixed with a "hidden" setting :)

Make sure the box highlighted below is NOT checked
Not sure what it actually means, but you will not get the "because of settings...External...Broken" message.

Also, No need to reinstall...(like ever ?)
You can go to the delete software area of windows...
right click on Solidworks, and select Change.
Follow the prompts, and you can run a a repair utility
that will sniff for corrupt stuff.

Answered with a tutorial: https://grabcad.com/tutorials/how-to-solve-reference-problem-in-solidworks-because-of-the-current-setting-the-reference-will-be-automatically-broken

 
Comments 0

you've probably clicked the "No external references" at the top

 
Comments 0