Problems with thikening a stitched surface in Solid Edge

I have a stitched surface model of five BlueSurf surfaces that I wish to thiken to create a solid. I get the message "non-manifold sheet body" and "Failed to offset or delete the face". Any clues to what I might be doing wrong? All surfaces are created with Bluesurf: two curves as cross sections and two curves as guidelines.

Answer
 
Comments 0

7 Answers

surfaces are probably poorly smoothed. There must be a tiny bump somewhere.l'épaisseur ne peut pas être supérieur au rayon minimum. Or create a thickening thickness 0. A you tried thickening of 0.001 to see if it ok?

 
Comments 0

Thank you very much for your reply.

I am able to create a thikness of 0.1 mm inwards and 2 mm outwards without error.

Do you have a tip on how to get smoother surfaces?

When you say the thikness cannot be greater than the minimum radius, does this include any radius in either the guide lines or the cross sections?

Best regards,

Erik

 
Comments 0

it depends on the precise form. Can you provide me the file so that I look?

 
Comments 0

more points you have to define your spline, you most likely to encounter this problem. The option curvature comb boosts to find out where the problem

 
Comments 0

To find out what the problem you can also use the inspect/Evaluate/geometry inspector or inspect/Analyze/ Curvature Shading/Settings/find in model

 
Comments 0

Wow, thank you for continued help! I forgot to answer your second question, but I am unfortunately not able to upload the CAD itself as it is not public at the moment. But your answers have been a great help. I am not quite there yet, but I have been able to clean up the surfaces a bit.

 
Comments 0