How to hide layers in assembly and parts independently?

though i hide layers in assembly, when i open part i should fine them in normal state

Answer
 
Comments 0

5 Answers

Hi PENDYALA.
if you want to hide layes in assambly of Pro/e , you have to make some changes with "config.pro" file.
Specify the value of the “def_layer” option as type-optionlayername.
and then ;
type-optionis the type of item that you want to place on that layer. The layernameis the name of the layer.
If a layer is set to Isolate, Pro/E blanks all other layers and allother items not associated to any layer. So, you need to configure it on your model tree.

 
Comments 0

Though i will hide layers of individual parts in assembly, i should be able to see them in when i open individual parts

 
Comments 3

Let me get this right, you want to hide layers of parts in your assembly but keep those layers on in part file ! OK if that is the question then it is very simple. You may have noticed that there are two trees in any pro E file. One is the model tree and one is a layer tree. The default tree which is shown is the model tree. Now in the assembly file go to the layer tree and hide all the unwanted layers. After which u need to right click and click on save status option (otherwise next time when you open the file the layers will appear again). This way the layers in part file will be visible but the same layers when you see in your assembly are hidden. Hope this solves your problem. Happy Modeling :)

 
Comments 0

Hi Arjun
Thank you for your response for my question posted, Even if you save the layers of the parts through assembly, the part file will hide the layers.

 
Comments 0

I understand I'm responding to a hilariously old thread, but thought I would update since I found a fix for myself. If you get into layer view and click the settings icon (hammer and screwdriver, no idea what it's actually called), then untick the Save status in sub models option, that seems to do the trick on my end.
You can have Creo automatically set this at startup by setting save_display_status_in_submodel as no.

 
Comments 0